KDE i RPMy

Linux - system operacyjny dla kazdego

mam problema, mam fd2 robilem update pakietow z okienek.
zasaalem tez oddzielnie kde 3.3.2 ale jak wklepie rpm -Uvh * to
wywala mi ze brakuje jakis bibliotek (znaczy krzyczy o zaleznosciach)
np:
lbmad.so.0
libImath.so.2
libfribidi.so.0
ale probelm w tym ze zassalem zrodelka ze stronek
./comfigure
make && make install
i nadal te same bledy sie pojawiaja, wiec nie szukalem
ani nie instalowalem kolejnych zrodelek skoro tych nie widzi
bibliotek ktrore niby zaintalowalem.
klepie np find / -name libmad.so.0 i znajduje mi w
/usr/local/lib/libmad.so.0
I jak to KDE zupgrajdowac do 3.3.2 no bo nie chcial bym
pomijac sprawdznai zaleznosci zeby sie co nei rozjechalo??
Czy moze trzeba dopisac gdzies sciezke bo brakuej moze sciezki
do jakiegos katalogu albo linki dorobic symboliczne? Zrobilem
symboliczny link do tej np biblioteki libmad.so.0 w lib ale tez
wywalal blad :[ wrrrr

o co chodzi?
Lukas denied rebel lies:


O to, że rpm nie ma pojęcia gdzie i jakie pliki sobie zainstalowałeś ze
źródeł. Rpm ma bazę zainstalowanych pakietów i tam sprawdza czy są
zainstalowane odpowiednie pakiety (zawierające potrzebne pliki). W
dystrybucji pakietowej mieszanie ich z tarbalami jest zwykle
proszeniem się o kłopoty - w każdym razie trzeba bardzo uważać i
wkładać więcej wysiłku w utrzymanie porządku.
Możesz albo ściągać rpm-y binarne, albo *.src.rpm i kompilować, albo
źródła, kompilować i instalować checkinstallem (który stworzy rpm-a).

A najlepiej używaj apt-a (;)
znaczy jak robilem ./configure i make && make install
no to chyba powinien wrzucic tak zeby bylo jasne gdzie i co??
A ewentualnie jak mozna to naprawic zeby wiedzial gdzie to jest?

Rpm ma bazę zainstalowanych pakietów i tam sprawdza czy są

znaczy chodzi ci o kde?? czy te biblioteki??

i kompilować, albo

nie mam czegos takiego jak checkinstall :/
sorki ale nei ejstem az tak advanced user



a czegos takiego jak apt tez nie mam :/ jakis help?? link do krotkiego
opisu??
Na te i inne pytania znajdziesz odpowiedź na stronie rpm.pbone.net

Jeśli chcesz samodzielnie instalować (a tym bardziej kompilować KDE),
przeczytaj dokładnie dokumentację na ich stronie. Znaczenie ma nawet to w
jakiej kolejności instaluje się pakiety.
Przy ręcznej aktualizacji konflikty to rzecz normalna i trzeba włożyć w to
trochę pracy.
Za to apt-get poradzi sobie bez większych problemów...

./KonMan
no tak ale na stronce czytamy
apt-get.org is intended as a place for people to share useful APT
(Advanced Package Tool) sources for the Debian operating system.

a ja uzywam fedora 2

widac bede musial sie pomordowac, pokompilowalem checkinstall pakiety i
poinstalowalem ale jeszcze brakuje ich calkiem sporo
No i?
ftp://ftp.pbone.net/mirror/dag.wieers.com/packages/apt/apt-0.5.15cnc6-3.1.fc2.dag.i386.rpm
+ GUI:
ftp://ftp.icm.edu.pl/vol/rzm8/linux-dag/fedora/2/en/i386/RPMS.dag/synaptic-0.55.1-1.1.fc2.rf.i386.rpm


Czas nie zając... a kompilowanie jest całkiem przyjemne, co? :)

./KonMan
A lyzka na to - niemozliwe!
taaa a swistak siedzi i zawija je w te srebreka.
tylko jaki to ma zwiazek z...??
A ja mam apt-get na fedore-core. Tak trudno wpisac w rpb.pbone.net "apt-
get" i poszukac paczki dla fc2?
Rafal 'Raf256' Maj denied rebel lies:


Temat 'apt tylko na Debianie' dopisuję do swojej listy tematów
żelaznych na grupie...