SCSI Software RAID problem z synchronizacja

Linux - system operacyjny dla kazdego

Wtam mam problem z synchronizacja raid 1 (mirror)
przy instalacji wszystko było ok, raid odpalil system chodzil,
zachcialo mi sie sprawdzic raid (musialem):

raidsetfaulty /dev/md0 /dev/sdb1
raidsetfaulty /dev/md1 /dev/sdb2
raidsetfaulty /dev/md2 /dev/sdb5
raidsetfaulty /dev/md3 /dev/sdb6

nagrałem na partycję /dev/md3 kilka duzych plików (ok 1,5GB)

wszystko ok, potem:
echo "scsi remove-single-device 0 00 03 00" > /proc/scsi/scsi

na razie wszystko dobrze, to jedziemy dalej, wyjąłem dysk, odczekałem
chwilę, włożyłem spowrotem:
echo "scsi add-single-device 0 00 03 00" > /proc/scsi/scsi

po około 15s dysk się rozpędził i już można było na nim pracować, to
jadę dalej:
raidhotadd /dev/md3 /dev/sdb6
jest ok, ale nie całkiem, po sprawdzeniu:
cat /proc/mdstat:
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5]
[raid4] [faulty]

md3 : active raid1sdb6[0] sda6[1]
13124992 blocks [2/1] [UU]

w massages mam to:



speed: 1000 KB/sec/disc.

bandwidth (but not more than 200000 KB/sec) for reconstruction.

13124992 blocks.


wygląda jakby synchronizacja odbywała się "BEZ CZASU", a powinna trwać
ok 8 min (13GB)

macie jakies pomysły, bo meczę się z tym już 3 dni i mnie trafia?

nie jest to mój pierwszy raid, kilka już postawiłem, nie było
problemów, tez testowałem itp..

wymieniałem dyski, dawałem różne (mam 4 szt)
XXX


A gdzie bylo:
raidhotremove??? Powinno byc w miejscu XXX.
Czyli:
raidhotremove /dev/md3 /dev/sdb3 (to samo oczywiscie dla pozostalych
raidow na dysku /dev/sdb).

Nie usuwasz dysku, dodajesz... system twierdzi, ze dalej ma dokladnie
ten sam dysk fizyczny. A ze dysk zostal po drodze zatrzymany, to go
nie interesuje.

Jacek
a widzisz, poszedłem na "rutynę", i gdzies mi to "wywiało", dzięki
bardzo, sprawdziłem, juz chodzi :):):)
Mimo wszystko zachowuje się to źle. Jaki kernel?

Pozdrawiam,

Krzysztof Oledzki